The OpenShift forums have been retired, but you can still read and search them.
For the most up-to-date information about how to use OpenShift please visit

Not able to push repo

I am trying to push repo in the cloub but I am getting following error :

rockvilla@CodeMachine:/var/www/nisargaresort$ git push
Counting objects: 9, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (5/5), done.
Writing objects: 100% (5/5), 473 bytes, done.
Total 5 (delta 4), reused 0 (delta 0)
remote: restart_on_add=false
remote: httpd (no pid file) not running
remote: /usr/libexec/openshift/cartridges/abstract/info/lib/util: line 982: /var/lib/openshift/0afc2085c8d341ef85f5c8057885035c/app-root/runtime/repo/.openshift/action_hooks/post_stop_php-5.3: Permission denied
remote: Failed to stop php-5.3
To ssh://
 ! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'ssh://'

There is nothing related to this problem on the net? Can anyone help me here? thanx in advance

Also if i do this rhc app start -a nisargaresort -d

Problem reported from server. Response code was 500.
Cartridge return code: 121
Exit Code: 143
api_c: placeholder
broker_c: namespacerhloginsshapp_uuiddebugaltercartridgecart_typeactionapp_nameapi
API version:    1.1.3
Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support.

I am checking with our dev ops to see if there is something wrong with the node your application is running on. Please stay tuned. Meanwhile, can you give these commands a try:

  • rhc app force-stop -a nisargaresort -d
  • rhc app start -a nisargaresort -d

I have similar issue failed to push into a newly created application. I tried restarting the app on the console as well. I also tried to delete the application and started over but no luck. I followed Grant Shipley Beershift example carefully and here is what I got when I do $ git push openshift

To ssh://
 ! [rejected]        master -> master (non-fast-forward)
error: failed to push some refs to 'ssh://'
hint: Updates were rejected because the tip of your current branch is behind
hint: its remote counterpart. Merge the remote changes (e.g. 'git pull')
hint: before pushing again.
hint: See the 'Note about fast-forwards' in 'git push --help' for details.

Regarding the git error you are getting, please check suggestions from here:

I followed instructions from beershift github readme and I did not encounter the same error message.